lirc doesn't work under 2.6.12 kernel

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

lirc doesn't work under 2.6.12 kernel

Robert La Ferla
My lirc serial stopped working after upgrading to 2.6.12.  I did a fresh
cvs update, configure and make install AFTER installing the new kernel.  
How can I diagnose the problem?  Anyone have lirc working on 2.6.12 and
Fedora Core 3?




-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Reply | Threaded
Open this post in threaded view
|

Re: lirc doesn't work under 2.6.12 kernel

Eli Crumrine
Sun, 19 Jun 2005 22:12:14 -0400 | Robert La Ferla <[hidden email]>

> My lirc serial stopped working after upgrading to 2.6.12.  I did a fresh
> cvs update, configure and make install AFTER installing the new kernel.  
> How can I diagnose the problem?  Anyone have lirc working on 2.6.12 and
> Fedora Core 3?
>

I just updated to 2.6.12 with the same kernel options as before, and my lirc works fine.
(Using mceusb though).


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Reply | Threaded
Open this post in threaded view
|

Re: lirc doesn't work under 2.6.12 kernel

Robert La Ferla
I had a bad link to my kernel source but even with the corrected link,
rebuild+install of lirc and reboot, it doesn't work.  Is there a debug
switch so I can better diagnose the problem?  BTW lircd shows up in my
chkconfig but lircd doesn't seem to be running after system startup.  If
I run it manually, using sh /etc/rc.d/init.d/lircd start, it starts up
but doesn't do anything.  This was working fine under 2.6.11-7.

Ideas?

EC wrote:

>Sun, 19 Jun 2005 22:12:14 -0400 | Robert La Ferla <[hidden email]>
>
>  
>
>>My lirc serial stopped working after upgrading to 2.6.12.  I did a fresh
>>cvs update, configure and make install AFTER installing the new kernel.  
>>How can I diagnose the problem?  Anyone have lirc working on 2.6.12 and
>>Fedora Core 3?
>>
>>    
>>
>
>I just updated to 2.6.12 with the same kernel options as before, and my lirc works fine.
>(Using mceusb though).
>  
>



-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Reply | Threaded
Open this post in threaded view
|

Re: lirc doesn't work under 2.6.12 kernel

Eli Crumrine
It is quite likely that your lirc device file has just moved to /dev/lirc instead of
/dev/lirc/0.  You can use -d <correct device> to fix the problem, and edit your init
scripts accordingly.  On my system, this device changes for no reason sometimes.  What I
did is add a simple
if [ -e /dev/lirc/0 ]; then
        $LIRC_ARGS="-d /dev/lirc/0"
else
        $LIRC_ARGS="-d /dev/lirc"
fi
To my /etc/init.d/lirc.  Its a bit ugly, but works fine.

Mon, 20 Jun 2005 20:23:03 -0400 | Robert La Ferla <[hidden email]>

> I had a bad link to my kernel source but even with the corrected link,
> rebuild+install of lirc and reboot, it doesn't work.  Is there a debug
> switch so I can better diagnose the problem?  BTW lircd shows up in my
> chkconfig but lircd doesn't seem to be running after system startup.  If
> I run it manually, using sh /etc/rc.d/init.d/lircd start, it starts up
> but doesn't do anything.  This was working fine under 2.6.11-7.
>
> Ideas?
>
> EC wrote:
>
> >Sun, 19 Jun 2005 22:12:14 -0400 | Robert La Ferla <[hidden email]>
> >
> >  
> >
> >>My lirc serial stopped working after upgrading to 2.6.12.  I did a fresh
> >>cvs update, configure and make install AFTER installing the new kernel.  
> >>How can I diagnose the problem?  Anyone have lirc working on 2.6.12 and
> >>Fedora Core 3?
> >>
> >>    
> >>
> >
> >I just updated to 2.6.12 with the same kernel options as before, and my lirc works
> >fine.
> >(Using mceusb though).
> >  
> >
>
>
>
> -------------------------------------------------------
> SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
> from IBM. Find simple to follow Roadmaps, straightforward articles,
> informative Webcasts and more! Get everything you need to get up to
> speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Reply | Threaded
Open this post in threaded view
|

Re: lirc doesn't work under 2.6.12 kernel

Robert La Ferla
I tried both /dev/lirc and /dev/lirc0 and neither worked.  :-(

EC wrote:

>It is quite likely that your lirc device file has just moved to /dev/lirc instead of
>/dev/lirc/0.  You can use -d <correct device> to fix the problem, and edit your init
>scripts accordingly.  On my system, this device changes for no reason sometimes.  What I
>did is add a simple
>if [ -e /dev/lirc/0 ]; then
> $LIRC_ARGS="-d /dev/lirc/0"
>else
> $LIRC_ARGS="-d /dev/lirc"
>fi
>To my /etc/init.d/lirc.  Its a bit ugly, but works fine.
>
>Mon, 20 Jun 2005 20:23:03 -0400 | Robert La Ferla <[hidden email]>
>
>  
>
>>I had a bad link to my kernel source but even with the corrected link,
>>rebuild+install of lirc and reboot, it doesn't work.  Is there a debug
>>switch so I can better diagnose the problem?  BTW lircd shows up in my
>>chkconfig but lircd doesn't seem to be running after system startup.  If
>>I run it manually, using sh /etc/rc.d/init.d/lircd start, it starts up
>>but doesn't do anything.  This was working fine under 2.6.11-7.
>>
>>Ideas?
>>    
>>


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click