Re: [mythtv-users] Lircd won't start correctly (Ubuntu PPA:s updated)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [mythtv-users] Lircd won't start correctly (Ubuntu PPA:s updated)

Alec Leamas


On 25/10/15 22:10, Don Brett wrote:
>
>
> -Trying to install 0.9.3a-1, but getting some resistance.  Tried
> adding the PPA links to /etc/apt/source.list, but the software updater
> complained about it.
I did  sudo add-apt-repository ppa:leamas-alec/lirc-0.9.3 which worked fine?

> /var/lib/dpkg/info/lirc.postinst: 5: /var/lib/dpkg/info/lirc.postinst:
> systemd-tmpfiles: not found
> dpkg: error processing package lirc (--configure):
>  subprocess installed post-installation script returned error exit
> status 127
> Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
> Errors were encountered while processing:
>  lirc
> E: Sub-process /usr/bin/dpkg returned an error code (1)

I. e., trusty hasn't systemd, nor can it be installed. I have updated my
ppas to use the vivid branch (15.04). While on it, I updated the 0.9.4
snapshot as of today. It is certainly possible to package lirc for
trusty, the systemd dependencies are not that hard. (there should be no
buildtime deps). But a lot of the documentation and some tools assumes
systemd.

Cheers!

--alec







------------------------------------------------------------------------------
Loading...