Quantcast

No response from irw and errors from mode2 when using lirc-0.9.4a in Fedora 24 after upgrade

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

No response from irw and errors from mode2 when using lirc-0.9.4a in Fedora 24 after upgrade

Jerry Chapman
I don't get any response from irw at all now.  When I try mode2, I get this after pressing one button:

[root@sirius lirc]# mode2 --driver devinput --device /dev/lirc0
Using driver devinput on device /dev/lirc0
Trying device: /dev/lirc0
Using device: /dev/lirc0
Warning: Running as root.
Partial read 8 bytes on /dev/lirc0[root@sirius lirc]#

[root@sirius lirc]# systemctl status lircd.service
● lircd.service - Flexible IR remote input/output application support
   Loaded: loaded (/usr/lib/systemd/system/lircd.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2016-07-04 12:06:36 EDT; 10min ago
     Docs: man:lircd(8)
           http://lirc.org/html/configure.html
 Main PID: 6362 (lircd)
    Tasks: 1 (limit: 512)
   CGroup: /system.slice/lircd.service
           └─6362 /usr/sbin/lircd --nodaemon

Jul 04 12:06:42 sirius lircd[6362]: lircd-0.9.4a[6362]: Notice: accepted new client on /var/run/lirc/lircd
Jul 04 12:06:42 sirius lircd[6362]: lircd-0.9.4a[6362]: Info: initializing 'auto'
Jul 04 12:06:42 sirius lircd-0.9.4a[6362]: Notice: accepted new client on /var/run/lirc/lircd
Jul 04 12:06:42 sirius lircd[6362]: lircd-0.9.4a[6362]: Info: Using device: /dev/input/event4
Jul 04 12:06:42 sirius lircd-0.9.4a[6362]: Info: initializing 'auto'
Jul 04 12:06:42 sirius lircd-0.9.4a[6362]: Info: Using device: /dev/input/event4
Jul 04 12:06:47 sirius lircd[6362]: lircd-0.9.4a[6362]: Info: removed client
Jul 04 12:06:47 sirius lircd[6362]: lircd-0.9.4a[6362]: Info: closing '/dev/input/event4'
Jul 04 12:06:47 sirius lircd-0.9.4a[6362]: Info: removed client
Jul 04 12:06:47 sirius lircd-0.9.4a[6362]: Info: closing '/dev/input/event4'
[root@sirius lirc]#

[root@sirius ~]# cat /sys/class/rc/rc0/protocols
other unknown rc-5 nec rc-6 jvc sony rc-5-sz sanyo sharp mce_kbd xmp [lirc]
[root@sirius ~]# cat /usr/lib/systemd/system/lircd.service
[Unit]
Documentation=man:lircd(8)
Documentation=http://lirc.org/html/configure.html
Description=Flexible IR remote input/output application support
Wants=lircd-setup.service
After=network.target lircd-setup.service

[Service]
Type=simple
ExecStart=/usr/sbin/lircd --nodaemon
; User=lirc
; Group=lirc

[Install]
WantedBy=multi-user.target
[root@sirius ~]#

I have a mceusb remote that has worked fine until this morning.  LIRC is not my strong suit but I've had the same configuration for ages now without issues.  I guess I'll plug in the FLIRC for now but I'd like to get this resolved if possible in LIRC as it works better with my setup.

Any help would be appreciated.

Thanks!

------------------------------------------------------------------------------
Attend Shape: An AT&T Tech Expo July 15-16. Meet us at AT&T Park in San
Francisco, CA to explore cutting-edge tech and listen to tech luminaries
present their vision of the future. This family event has something for
everyone, including kids. Get more information and register today.
http://sdm.link/attshape
Loading...