Quantcast

[Fwd: 0.7.1 - imon multimode - not a sausage from irw sadness :(]

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Fwd: 0.7.1 - imon multimode - not a sausage from irw sadness :(]

AlanM

Hi all,

I'm new here, I hope I am not asking questions that have been asked lots
already :) I am having a few problems getting lirc and imon to work and
was wondering if anyone can point me in the right kind of direction or
have some suggestions about how I can get any further..

I compiled lircd for the imon refering to the RPM src for my curent
kernel (2.6.11-1.27_FC3). All built and made fine. I modprobe the
devices and get /dev/lirc etc. If I run mode2 I get a good looking set
of values up (similar to what I have seen in other articles)

I run lircd and no errors. Then I fire up irw, but see -nothing- at all!

I enabled debug and see in the lircd log file as below. It seems to go
wrong on "bad pre data". Could this be a mis-configured lircd.conf file
or something more sinister? The lircd.conf was inserted at install and
is the same as the imon one in remotes/

I also have been looking at syslog and the debug is very verbose and I
can't really make head nor tail of it (!)

Please help

thanks

Alan



Jun 29 19:35:59 fe-lounge lircd 0.7.1: caught signal
Jun 29 19:36:54 fe-lounge lircd 0.7.1: started server socket
Jun 29 19:36:54 fe-lounge lircd 0.7.1: parsing remote
Jun 29 19:36:54 fe-lounge lircd 0.7.1: parsing IMON_MultiMedian remote
Jun 29 19:36:54 fe-lounge lircd 0.7.1: config file read
Jun 29 19:36:54 fe-lounge lircd 0.7.1: lircd(imon) ready
Jun 29 19:37:46 fe-lounge lircd 0.7.1: registering local client
Jun 29 19:37:46 fe-lounge lircd 0.7.1: accepted new client on /dev/lircd
Jun 29 19:37:46 fe-lounge lircd 0.7.1: driver supports receiving
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync
Jun 29 19:37:52 fe-lounge lircd 0.7.1: header
Jun 29 19:37:52 fe-lounge lircd 0.7.1: pre: 108
Jun 29 19:37:52 fe-lounge lircd 0.7.1: code: 21de
Jun 29 19:37:52 fe-lounge lircd 0.7.1: bad pre data
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: decoding failed for all remotes
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync
Jun 29 19:37:52 fe-lounge lircd 0.7.1: header
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on bit 1
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on pre_data
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on pre
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: decoding failed for all remotes
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync


Hi all,

I'm new here, I hope I am not asking questions that have been asked lots
already :) I am having a few problems getting lirc and imon to work and
was wondering if anyone can point me in the right kind of direction or
have some suggestions about how I can get any further..

I compiled lircd for the imon refering to the RPM src for my curent
kernel (2.6.11-1.27_FC3). All built and made fine. I modprobe the
devices and get /dev/lirc etc. If I run mode2 I get a good looking set
of values up (similar to what I have seen in other articles)

I run lircd and no errors. Then I fire up irw, but see -nothing- at all!

I enabled debug and see in the lircd log file as below. It seems to go
wrong on "bad pre data". Could this be a mis-configured lircd.conf file
or something more sinister? The lircd.conf was inserted at install and
is the same as the imon one in remotes/

I also have been looking at syslog and the debug is very verbose and I
can't really make head nor tail of it (!)

Please help

thanks

Alan



Jun 29 19:35:59 fe-lounge lircd 0.7.1: caught signal
Jun 29 19:36:54 fe-lounge lircd 0.7.1: started server socket
Jun 29 19:36:54 fe-lounge lircd 0.7.1: parsing remote
Jun 29 19:36:54 fe-lounge lircd 0.7.1: parsing IMON_MultiMedian remote
Jun 29 19:36:54 fe-lounge lircd 0.7.1: config file read
Jun 29 19:36:54 fe-lounge lircd 0.7.1: lircd(imon) ready
Jun 29 19:37:46 fe-lounge lircd 0.7.1: registering local client
Jun 29 19:37:46 fe-lounge lircd 0.7.1: accepted new client on /dev/lircd
Jun 29 19:37:46 fe-lounge lircd 0.7.1: driver supports receiving
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync
Jun 29 19:37:52 fe-lounge lircd 0.7.1: header
Jun 29 19:37:52 fe-lounge lircd 0.7.1: pre: 108
Jun 29 19:37:52 fe-lounge lircd 0.7.1: code: 21de
Jun 29 19:37:52 fe-lounge lircd 0.7.1: bad pre data
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: decoding failed for all remotes
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync
Jun 29 19:37:52 fe-lounge lircd 0.7.1: header
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on bit 1
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on pre_data
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed on pre
Jun 29 19:37:52 fe-lounge lircd 0.7.1: failed "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: decoding failed for all remotes
Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
Jun 29 19:37:52 fe-lounge lircd 0.7.1: sync

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Fwd: 0.7.1 - imon multimode - not a sausage from irw sadness :(]

Christoph Bartelmus
Hi!

AlanM "[hidden email]" wrote:
[...]
> already :) I am having a few problems getting lirc and imon to work and
[...]
> I enabled debug and see in the lircd log file as below. It seems to go
> wrong on "bad pre data". Could this be a mis-configured lircd.conf file
[...]
> Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
[...]
> Jun 29 19:37:52 fe-lounge lircd 0.7.1: bad pre data

Wrong config file. You should be using remotes/imon/lircd.conf.imon-rsc  
from the source package.

Christoph


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Fwd: 0.7.1 - imon multimode - not a sausage from irw sadness :(]

AlanM

Hi Christoph

Thanks for the fast response. That did the trick :)

Alan

Christoph Bartelmus wrote:

>Hi!
>
>AlanM "[hidden email]" wrote:
>[...]
>  
>
>>already :) I am having a few problems getting lirc and imon to work and
>>    
>>
>[...]
>  
>
>>I enabled debug and see in the lircd log file as below. It seems to go
>>wrong on "bad pre data". Could this be a mis-configured lircd.conf file
>>    
>>
>[...]
>  
>
>>Jun 29 19:37:52 fe-lounge lircd 0.7.1: trying "IMON_MultiMedian" remote
>>    
>>
>[...]
>  
>
>>Jun 29 19:37:52 fe-lounge lircd 0.7.1: bad pre data
>>    
>>
>
>Wrong config file. You should be using remotes/imon/lircd.conf.imon-rsc  
>from the source package.
>
>Christoph
>
>
>-------------------------------------------------------
>SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
>from IBM. Find simple to follow Roadmaps, straightforward articles,
>informative Webcasts and more! Get everything you need to get up to
>speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
>
>  
>



-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
Loading...