Driver version mismatch

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Driver version mismatch

VDR User
Hi. I just compiled lirc from git (0.10.0-devel.git+e3225584). I
noticed in my lircd.log:

lircd: Notice: Version: lircd 0.10.0-devel
...
lircd: Notice: Current driver: default
lircd: Notice: Driver API version: 3
lircd: Notice: Driver  version: 0.9.4

Shouldn't the driver also be 0.10.0-devel?

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Driver version mismatch

Bengt Martensson-2
On 06/25/17 05:02, VDR User wrote:

> Hi. I just compiled lirc from git (0.10.0-devel.git+e3225584). I
> noticed in my lircd.log:
>
> lircd: Notice: Version: lircd 0.10.0-devel
> ...
> lircd: Notice: Current driver: default
> lircd: Notice: Driver API version: 3
> lircd: Notice: Driver  version: 0.9.4
>
> Shouldn't the driver also be 0.10.0-devel?

No. It is quite conceivable that lircd and a particular driver have
different versions and even release managements. May even come from
different sources. The API version must be compatible though.

A few years ago, Alec synced all the driver (better: "plugin") versions
with the then-current Lirc version. IMHO, this was possibly not a good
decision.

Greetz,

Bengt

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Loading...